0
تم الإنجاز

Mapped drives in win10

romeo.matkovic منذ 2 سنة في Software / PC-DMIS تم التحديث من قبل Gábor Tóth منذ 5 شهر 6

Dialog Save As or Open in win10 with 2018R1 doesn't work. PCDMIS doesn't see any network mapped drives or folder from Quick Access. Please fix that. because we cant work without that.

سيئ، أنا غير راض

Hello

 

I tried to turn off UAC but PCDMIS still doesn't see mapped drives.

I'm pretty sure that this is problem inside PCDMIS

All my other application n this PC works OK, only PCDMIS have problem with mapped drives

Please give me a solution for that and solve a problem a soon as possible

 

We can’t wait R2 to start work with our 30 CMMs! This is urgent!

We need mapped disk M because we use it in all our program for automatic printing a files.

 We have this in all our program (30 CMM x 200 programs =  6000 programs aproximately)

 ASSIGN/PRINTPATH="M:\\" + PT_NAME + "_" + C2.INPUT + "_" + C4.INPUT + "_" + C3.INPUT + ".rtf"


In our plant M disk is: \\bunts22\usr\mlq\mjerenja3D and this M disk we need to all PC-s with PCDMIS


Thank you very much!

علامة الرضا من romeo.matkovic منذ 2 سنة

This also can be caused by the User Account Control (UAC) is turned on.

تم الإنجاز

As Dave indicates, this appears to be a windows problem. The File Open and Save as dialogs in PC-DMIS are actually windows explorer. If you google, you will see a lot of similar problems in applications. It seems that Windows 10 is sensitive on UAC, and also if you run an application with different privileges to those used to map the drive. If you run PC-DMIS as admin, and the drive was mapped with normal privilege - try running them at the same level.


In PC-DMIS 2018 R2, I would note that we've swapped to use a newer (more modern) version of Explorer for File Open, Save, etc, and the mapping problem does not happen there, so I'm marking this as resolved.

Hello

 

I tried to turn off UAC but PCDMIS still doesn't see mapped drives.

I'm pretty sure that this is problem inside PCDMIS

All my other application n this PC works OK, only PCDMIS have problem with mapped drives

Please give me a solution for that and solve a problem a soon as possible

 

We can’t wait R2 to start work with our 30 CMMs! This is urgent!

We need mapped disk M because we use it in all our program for automatic printing a files.

 We have this in all our program (30 CMM x 200 programs =  6000 programs aproximately)

 ASSIGN/PRINTPATH="M:\\" + PT_NAME + "_" + C2.INPUT + "_" + C4.INPUT + "_" + C3.INPUT + ".rtf"

In our plant M disk is: \\bunts22\usr\mlq\mjerenja3D and this M disk we need to all PC-s with PCDMIS

Thank you very much!

I did a test myself (I'm using Windows 10 and PC-DMIS 2018 R1). My test results appear to back up what I pasted previously.


If I map a drive (using standard user rights in a command shell)


And I run PC-DMIS using standard user rights, then I can see the drive in This PC section


And I can right click it and pin it to Quick Access




If I now close PC-DMIS, and run as administrator, the drive is no longer available to it.

It is missing from This PC


And the previously pinned Quick Access link does not work.




If I now remap the drive as administrator (by running the map command in Command Prompt running as admin...), then I can access the drive when PC-DMIS is also running as administrator



The content in this File Open, Save is coming from Windows Explorer - a Microsoft component. PC-DMIS 2018 R1 uses a very old explorer version (Which is why the File Open looks quite old fashioned). 2018 R2 uses a more modern explorer version, which appears to have fixed this bug. The reason your other applications seem to work OK is likely because they are using the more modern explorer to do the file open dialog that we now also use.


In summary - ensure your privileges are consistent between how you map your drive, and how you run PC-DMIS.


Hope this helps.

Romeo,

What I end up doing was placing a Case (Ticket) to Tech Support for this issue and they can help you with adjusting the settings. 


The method that work for the issue I was having with not seeing the Network drives running PC-DMIS as Administrator was to create a new DWORD Value in the registry.


Here is the link that was given to me from Tech Support to Microsoft Docs.

Some Programs Cannot Access Network Locations When UAC Is Enabled


Here is another link How to turn off and disable UAC in Windows 10

How to turn off and disable UAC in Windows 10


Now if you have never edit or created a new value in the windows registry before then you really need to call Tech Support or have your IT department do this for you. 


Neil, 

The UAC enable is additional protection from dangerous apps and viruses which can elevate silently if it is disabled.

Maybe Hexagon needs to look into this issue more for the older versions of PC-DMIS.

Hi, 

Since 2013 I need modify regedit by manualy.(about 20 times )

Could you improve the install process that automaticaly create DWord and so on?

Thanks in advance!

خدمة دعم العملاء من خلال UserEcho